vlc: security bump to version 2.1.6
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 27 Feb 2015 15:51:58 +0000 (12:51 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Feb 2015 16:13:57 +0000 (17:13 +0100)
* Fix heap overflow in decomp stream filter
* Fix buffer overflow in updater
* Fix potential buffer overflow in schroedinger encoder
* Fix null-pointer dereference in DMO decoder
* Fix buffer overflow in parsing of string boxes in mp4 demuxer
* Fix SRTP integer overflow
* Fix potential crash in zip access
* Fix read overflow in Ogg demuxer

And also add hash file.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.hash [new file with mode: 0644]
package/vlc/vlc.mk

diff --git a/package/vlc/vlc.hash b/package/vlc/vlc.hash
new file mode 100644 (file)
index 0000000..718a0e6
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://get.videolan.org/vlc/2.1.6/vlc-2.1.6.tar.xz.sha256
+sha256 1b76cf4b96e18cf224d21b91343f7e579790c5d3e499c8a230f53da695687c04        vlc-2.1.6.tar.xz
index 9d99de636fbd23c8246ec40f0a2300e05f63b3af..56006b5b460cfe5174497b41047493409edcc420 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-VLC_VERSION = 2.1.5
+VLC_VERSION = 2.1.6
 VLC_SITE = http://get.videolan.org/vlc/$(VLC_VERSION)
 VLC_SOURCE = vlc-$(VLC_VERSION).tar.xz
 VLC_LICENSE = GPLv2+ LGPLv2.1+