package/gstreamer1/gst1-plugins-bad: explicitly enable _GNU_SOURCE for festival/glibc...
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2020 08:50:14 +0000 (09:50 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2020 08:50:14 +0000 (09:50 +0100)
festival fails to built with glibc 2.18 due to fopen and the h_addr field in
struct hostent:

../gst/festival/gstfestival.c: In function 'gst_festival_chain':
../gst/festival/gstfestival.c:273:3: warning: implicit declaration of function 'fdopen' [-Wimplicit-function-declaration]
   fd = fdopen (f, "wb");
   ^
../gst/festival/gstfestival.c:273:6: warning: assignment makes pointer from integer without a cast [enabled by default]
   fd = fdopen (f, "wb");
      ^
../gst/festival/gstfestival.c: In function 'festival_socket_open':
../gst/festival/gstfestival.c:367:45: error: 'struct hostent' has no member named 'h_addr'
     memmove (&serv_addr.sin_addr, serverhost->h_addr, serverhost->h_length);
                                             ^

Both of which are hidden behind _GNU_SOURCE in glibc 2.18, so enable that to
fix this build issue.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 86aa345b00ac48c24d9450e72a1f40c1eaa1e6d9..a9111ebdb83821dbb36cb2e263817ea73fdfef2d 100644 (file)
@@ -13,7 +13,7 @@ GST1_PLUGINS_BAD_INSTALL_STAGING = YES
 GST1_PLUGINS_BAD_LICENSE_FILES = COPYING
 GST1_PLUGINS_BAD_LICENSE = LGPL-2.0+
 
-GST1_PLUGINS_BAD_CFLAGS = $(TARGET_CFLAGS) -std=c99
+GST1_PLUGINS_BAD_CFLAGS = $(TARGET_CFLAGS) -std=c99 -D_GNU_SOURCE
 GST1_PLUGINS_BAD_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 
 GST1_PLUGINS_BAD_CONF_OPTS = \