libgpgme: fix musl build with argp-standalone
authorBaruch Siach <baruch@tkos.co.il>
Tue, 24 May 2016 12:30:17 +0000 (15:30 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 24 May 2016 19:50:36 +0000 (21:50 +0200)
The libgpgme configure script does not detect the error_t type under musl,
because musl does not define error_t in errno.h. As a result config.h adds a
local definition of error_t. When argp-standalone is present this local
definition collides with the error_t typedef in argp.h. Assume we always have
error_t when argp-standalone is present.

Fixes:
http://autobuild.buildroot.net/results/656/6566a1c77983404d90920997bfd15bd98c7ddde7/
http://autobuild.buildroot.net/results/a7b/a7b92ad68ff6e13d20ff44e955dc5748b2efd6a4/
http://autobuild.buildroot.net/results/0db/0db1b2aa0969d6cbae57b1400b7b766a5988abf9/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libgpgme/libgpgme.mk

index 186809985ca403500a218bb00664a3c2fd0b87de..574ddd6be14d4c4dda76c94ec3f09d2c2bcdb3ae 100644 (file)
@@ -23,7 +23,9 @@ LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \
 
 # Handle argp-standalone or it errors out during build
 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
-LIBGPGME_CONF_ENV += LIBS="-largp"
+# musl libc does not define error_t in errno.h, but argp.h does.
+# Assume we have error_t to avoid collision with the argp.h error_t.
+LIBGPGME_CONF_ENV += LIBS="-largp" ac_cv_type_error_t=yes
 LIBGPGME_DEPENDENCIES += argp-standalone
 endif