portmap: use <pkg>_INSTALL_INIT_SYSV mechanism
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:17:55 +0000 (15:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 21:43:28 +0000 (22:43 +0100)
We also switch to using a full destination path as the second argument
of $(INSTALL).

[Peter: use install -D as noted by Yann]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/portmap/portmap.mk

index 01895976a6a778026586405f002edfa2cd6a0a73..2bffb9e3c0c3440ac6e26d337855d7704f43c27d 100644 (file)
@@ -30,8 +30,10 @@ define PORTMAP_INSTALL_TARGET_CMDS
                $(TARGET_DIR)/usr/share/man/man8/pmap_dump.8
        $(INSTALL) -D $(@D)/pmap_set.8 \
                $(TARGET_DIR)/usr/share/man/man8/pmap_set.8
-       $(INSTALL) -m 0755 package/portmap/S13portmap \
-               $(TARGET_DIR)/etc/init.d
+endef
+
+define PORTMAP_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 0755 package/portmap/S13portmap $(TARGET_DIR)/etc/init.d/S13portmap
 endef
 
 $(eval $(generic-package))