new package: gsl the GNU Scientific Library.
authorSagaert Johan <sagaert.johan@skynet.be>
Tue, 20 Mar 2012 23:16:57 +0000 (00:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Aug 2012 17:37:43 +0000 (19:37 +0200)
[thomas.petazzoni@free-electrons.com:
 renamed package to 'gsl' to match upstream name.
 added license information.]

Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/gsl/Config.in [new file with mode: 0644]
package/gsl/gsl.mk [new file with mode: 0644]

index 3f46d3af0b601040f0ba67309c062dbdb02ba1d2..d6a66fd311ee6baf48f8b585d5520d37c41826e8 100644 (file)
@@ -457,6 +457,7 @@ source "package/libelf/Config.in"
 source "package/libevent/Config.in"
 source "package/libev/Config.in"
 source "package/libffi/Config.in"
+source "package/gsl/Config.in"
 source "package/libglib2/Config.in"
 source "package/libical/Config.in"
 source "package/libnspr/Config.in"
diff --git a/package/gsl/Config.in b/package/gsl/Config.in
new file mode 100644 (file)
index 0000000..92541da
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GSL
+       bool "gsl"
+       help
+         The GNU Scientific Library (GSL) is a numerical library for
+         C and C++ programmers.  The library provides a wide range of
+         mathematical routines such as random number generators,
+         special functions and least-squares fitting. There are over
+         1000 functions in total with an extensive test suite.
+
+         http://www.gnu.org/software/gsl
diff --git a/package/gsl/gsl.mk b/package/gsl/gsl.mk
new file mode 100644 (file)
index 0000000..7196859
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# gnu gsl
+#
+#############################################################
+GSL_VERSION = 1.15
+GSL_SOURCE = gsl-$(GSL_VERSION).tar.gz
+GSL_SITE = $(BR2_GNU_MIRROR)/gsl
+GSL_INSTALL_STAGING = YES
+GSL_LICENSE = GPLv3
+GSL_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))