added python unicode selection to menu
authorMatthew Weber <mlweber1@rockwellcollins.com>
Wed, 8 Jan 2014 04:34:07 +0000 (22:34 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 22 Jan 2014 21:39:36 +0000 (22:39 +0100)
This patch is based on the original new pkg patch submitted last Jan
and is part of the "Patchwork oldest patches cleanup #5".

[Peter: fix CONF_OPT indentation]
Signed-off-by: Matt Weber <mlweber1@rockwellcollins.com>
Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python/Config.in
package/python/python.mk

index b1c0935415ad024e7749aff6d6f48ef271e597b7..a0c78c6788f8fc84b9879abfae60b6dd73d67aca 100644 (file)
@@ -84,6 +84,24 @@ config BR2_PACKAGE_PYTHON_UNICODEDATA
        help
          Unicode character database (used by stringprep module) (large).
 
+if BR2_PACKAGE_PYTHON_UNICODEDATA
+
+choice
+       prompt "Python unicode database format"
+       default BR2_PACKAGE_PYTHON_UCS2
+       help
+         Select Python unicode database format for target
+
+config BR2_PACKAGE_PYTHON_UCS2
+       bool "Universal Character Set 2-byte (UCS2)"
+
+config BR2_PACKAGE_PYTHON_UCS4
+       bool "Universal Character Set 4-byte (UCS4)"
+
+endchoice
+
+endif
+
 config BR2_PACKAGE_PYTHON_SQLITE
        bool "sqlite module"
        select BR2_PACKAGE_SQLITE
index bc42e8f14fc90f8dd915eed93ce49d415ddf9d3d..6187d66e7dbf1ff837c29e90d013f566adedd7e1 100644 (file)
@@ -102,6 +102,11 @@ ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
 PYTHON_CONF_OPT += --disable-unicodedata
 endif
 
+# Default is UCS2 w/o a conf opt
+ifeq ($(BR2_PACKAGE_PYTHON_UCS4),y)
+PYTHON_CONF_OPT += --enable-unicode=ucs4
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON_BZIP2),y)
 PYTHON_DEPENDENCIES += bzip2
 else