snmppp: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 14 Oct 2013 13:47:15 +0000 (10:47 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 14 Oct 2013 20:10:52 +0000 (22:10 +0200)
[Peter: add comment about why AUTORECONF is needed]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/snmppp/Config.in [new file with mode: 0644]
package/snmppp/snmppp.mk [new file with mode: 0644]

index 7af6d420bd53ecf123e99976166a78e4ddb1b3b4..0e6f86c0c3f8929b75a0f1a36a0dfcfd03a7addd 100644 (file)
@@ -637,6 +637,7 @@ source "package/omniorb/Config.in"
 source "package/openpgm/Config.in"
 source "package/ortp/Config.in"
 source "package/slirp/Config.in"
+source "package/snmppp/Config.in"
 source "package/usbredir/Config.in"
 source "package/wvstreams/Config.in"
 source "package/zeromq/Config.in"
diff --git a/package/snmppp/Config.in b/package/snmppp/Config.in
new file mode 100644 (file)
index 0000000..9757814
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_SNMPPP
+       bool "snmp++"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_OPENSSL
+       help
+         SNMP++v3.x is a C++ API which supports SNMP v1, v2c, and v3.
+
+         http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html
+
+comment "snmp++ requires a toolchain with threads and C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/snmppp/snmppp.mk b/package/snmppp/snmppp.mk
new file mode 100644 (file)
index 0000000..8e8fceb
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# snmp++
+#
+################################################################################
+
+SNMPPP_VERSION = 3.3.0
+SNMPPP_SOURCE = snmp++v$(SNMPPP_VERSION).tar.gz
+SNMPPP_SITE = http://www.agentpp.com
+SNMPPP_DEPENDENCIES = openssl host-pkgconf
+SNMPPP_INSTALL_STAGING = YES
+# no configure script in tarball
+SNMPPP_AUTORECONF = YES
+SNMPPP_LICENSE = SNMP++
+SNMPPP_LICENSE_FILES = snmp_pp/snmp_pp.cpp
+
+$(eval $(autotools-package))