bluez-utils: Add GATT support
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>
Fri, 20 Dec 2013 14:20:23 +0000 (15:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 20 Dec 2013 14:43:57 +0000 (15:43 +0100)
This allows to compile gatttool which can help use Bluetooth Low Energy
devices.

Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bluez_utils/Config.in
package/bluez_utils/bluez_utils.mk

index e08e9be2db951e99033ceb2dd9789ac5475b63ef..1315b9ef4166cb497b0ba7a0cfb81a41df576e0c 100644 (file)
@@ -36,6 +36,13 @@ config BR2_PACKAGE_BLUEZ_UTILS_USB
        help
          USB support
 
+config BR2_PACKAGE_BLUEZ_UTILS_GATT
+       bool "GATT support"
+       select BR2_PACKAGE_READLINE
+       help
+         Generic Attribute Profile (GATT) support. This provides profile
+         discovery and description services for Bluetooth Low Energy.
+         This will install the gatttool utility.
 endif
 
 comment "bluez-utils needs a toolchain w/ wchar, threads"
index 7038638a0748721ab7737414d1c08c2f4304dab5..4da2e6435c40462df2ed78315ae732603b6197bc 100644 (file)
@@ -37,6 +37,13 @@ BLUEZ_UTILS_CONF_OPT +=      \
        --disable-audio
 endif
 
+ifeq ($(BR2_PACKAGE_BLUEZ_UTILS_GATT),y)
+BLUEZ_UTILS_DEPENDENCIES += readline
+BLUEZ_UTILS_CONF_OPT += --enable-gatt
+else
+BLUEZ_UTILS_CONF_OPT += --disable-gatt
+endif
+
 # USB support
 ifeq ($(BR2_PACKAGE_BLUEZ_UTILS_USB),y)
 BLUEZ_UTILS_DEPENDENCIES += libusb