System config: split static-dev device table setting into seperate option
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Jul 2011 22:09:33 +0000 (00:09 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Jul 2011 22:09:33 +0000 (00:09 +0200)
As discussed here:

http://lists.busybox.net/pipermail/buildroot/2011-May/043251.html

Add BR2_ROOTFS_STATIC_DEVICE_TABLE for the extra device table file(s)
to create device nodes in /dev, rather than complicated logic in
BR2_ROOTFS_DEVICE_TABLE, making it complicated to move between static
and dynamic modes.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/common.mk
target/generic/Config.in

index 4d5051460d54dbd4bd8a61c53010e39c6419b420..f793ff962bf6d5ae4b65d587f10fbb4a3f80d8d8 100644 (file)
@@ -33,7 +33,8 @@
 
 FAKEROOT_SCRIPT = $(BUILD_DIR)/_fakeroot.fs
 FULL_DEVICE_TABLE = $(BUILD_DIR)/_device_table.txt
-ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE))
+ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE)) \
+       $(call qstrip,$(BR2_ROOTFS_STATIC_DEVICE_TABLE))
 
 define ROOTFS_TARGET_INTERNAL
 
index 7961beccc840ace8cb02eddd82e334e6a6fdb49d..a91de32124184b602bd7a0e1bbe2415a7d8a9eed 100644 (file)
@@ -33,18 +33,25 @@ config BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV
 endchoice
 
 config BR2_ROOTFS_DEVICE_TABLE
+       string "Path to the permission tables"
+       default "target/generic/device_table.txt"
+       help
+         Specify a space-separated list of permission table locations,
+         that will be passed to the makedevs utility to assign
+         correct owners and permissions on various files in the
+         target filesystem.
+
+         See package/makedevs/README for details on the usage and
+         syntax of these files.
+
+config BR2_ROOTFS_STATIC_DEVICE_TABLE
        string "Path to the device tables"
-       default "target/generic/device_table.txt target/generic/device_table_dev.txt" \
-               if BR2_ROOTFS_DEVICE_CREATION_STATIC
-       default "target/generic/device_table.txt" \
-               if (BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV || \
-                   BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV || \
-                   BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS)
+       default "target/generic/device_table_dev.txt"
+       depends on BR2_ROOTFS_DEVICE_CREATION_STATIC
        help
          Specify a space-separated list of device table locations,
          that will be passed to the makedevs utility to create all
-         the special device files and assign correct owners and
-         permissions on various files in the target filesystem.
+         the special device files under /dev.
 
          See package/makedevs/README for details on the usage and
          syntax of these files.