x11r7/libXt: don't install makestrs
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 19 Oct 2008 21:48:58 +0000 (21:48 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 19 Oct 2008 21:48:58 +0000 (21:48 -0000)
Don't install makestrs in the first place, instead of removing it
afterwards. Fixes cross-strip issue.

package/x11r7/xlib_libXt/xlib_libXt.mk

index cd4c116e3cc9a1367bad6ff7cc73ba3688a8adbb..e478780d0cd2555e476f93d694c1e8b117508adb 100644 (file)
@@ -13,10 +13,6 @@ XLIB_LIBXT_INSTALL_TARGET = YES
 XLIB_LIBXT_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
 XLIB_LIBXT_DEPENDENCIES = xlib_libSM xlib_libX11 xproto_kbproto xproto_xproto xcb-proto libxcb
 XLIB_LIBXT_CONF_ENV = CC_FOR_BUILD="/usr/bin/gcc -I$(STAGING_DIR)/usr/include"
-XLIB_LIBXT_CONF_OPT = --disable-malloc0returnsnull --enable-shared --disable-static
+XLIB_LIBXT_CONF_OPT = --disable-malloc0returnsnull --enable-shared --disable-static --disable-install-makestrs
 
 $(eval $(call AUTOTARGETS,package/x11r7,xlib_libXt))
-
-# the host makestrs shouldn't get installed in target
-$(XLIB_LIBXT_HOOK_POST_INSTALL):
-       rm -f $(TARGET_DIR)/usr/bin/makestrs