libostree: override path to gpg-error-config
authorMarcus Folkesson <marcus.folkesson@gmail.com>
Fri, 27 Jul 2018 19:40:32 +0000 (21:40 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 28 Jul 2018 13:53:33 +0000 (15:53 +0200)
libostree has begun to use `gpg-error-config` in their configuration
script.
Point out gpg-error-config in staging dir to avoid using the one
installed on the host system.

Fixes:
 http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libostree/Config.in
package/libostree/libostree.mk

index b62f4ea0a1d71e47b297036d1f6ffb8acb6c860b..4a6ab5464fb0a4ef4a69016f4f921bff33279bed 100644 (file)
@@ -1,15 +1,16 @@
 config BR2_PACKAGE_LIBOSTREE
        bool "libostree"
-       depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS # libgpgme
+       depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS # libgpgme, libgpg-error
        depends on !BR2_STATIC_LIBS # libfuse
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_WCHAR # libglib2
-       depends on BR2_USE_MMU # e2fsprogs, libfuse,libglib2, libgpgme
+       depends on BR2_USE_MMU # e2fsprogs, libfuse, libglib2, libgpgme
        # doesn't build with musl due to lack of TEMP_FAILURE_RETRY()
        depends on !BR2_TOOLCHAIN_USES_MUSL
        select BR2_PACKAGE_E2FSPROGS
        select BR2_PACKAGE_LIBFUSE
        select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBGPG_ERROR
        select BR2_PACKAGE_LIBGPGME
        select BR2_PACKAGE_XZ
        help
index 24eda0d1db37e57ccf693343b8eae6e12f167a48..349e6a08818274a4a3eabc0514a7c83443af3cf0 100644 (file)
@@ -10,9 +10,11 @@ LIBOSTREE_SITE = https://github.com/ostreedev/ostree/releases/download/v$(LIBOST
 
 LIBOSTREE_LICENSE = LGPL-2.0+
 LIBOSTREE_LICENSE_FILES = COPYING
-LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
+LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpg-error libgpgme xz
 LIBOSTREE_INSTALL_STAGING = YES
 
+LIBOSTREE_CONF_ENV = \
+       GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
 LIBOSTREE_CONF_OPTS += \
        --with-gpgme-prefix=$(STAGING_DIR)/usr \
        --disable-gtk-doc \