webkit: fix misc build issues
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Jun 2010 09:31:42 +0000 (11:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Jul 2010 08:32:35 +0000 (10:32 +0200)
Webkit depends on libjpeg, so add it as a dependency. Webkit also uses
icu but fails to find it if we don't pass ac_cv_path_icu_config to its
./configure script.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webkit/webkit.mk

index 39debd36230aaca56ffa24eb7f8de0760dece4e1..fc355ceecd2b9b99108715a75a2feb3cabe716e8 100644 (file)
@@ -12,8 +12,9 @@ WEBKIT_INSTALL_TARGET = YES
 WEBKIT_LIBTOOL_PATCH = NO
 
 WEBKIT_DEPENDENCIES = host-flex host-gperf icu curl libxml2 libxslt    \
-                       libgtk2 sqlite enchant libsoup
+                       libgtk2 sqlite enchant libsoup jpeg
 
+WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
        WEBKIT_CONF_OPT += --with-target=x11