package/systemd: add optional support for firstboot
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:03 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 10:28:29 +0000 (12:28 +0200)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Maxime: Add default y]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 20b4e28068d028079ab9ee4b7832ac8e1c36edd8..a2cf4be6710612f6edfdfd02d9b38df3385fecfa 100644 (file)
@@ -150,6 +150,15 @@ config BR2_PACKAGE_SYSTEMD_SYSUSERS
 
          http://www.freedesktop.org/software/systemd/man/systemd-sysusers.html
 
+config BR2_PACKAGE_SYSTEMD_FIRSTBOOT
+       bool "enable firstboot support"
+       default y
+       help
+         systemd-firstboot initializes the most basic system settings
+         interactively on the first boot.
+
+         http://www.freedesktop.org/software/systemd/man/systemd-firstboot.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index 0520ced4c6594cb1945dafe757be22a3fa22ba90..c5d6478f43c08c4527ea0b2716b85d8359c4178d 100644 (file)
@@ -171,6 +171,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-sysusers
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_FIRSTBOOT),y)
+SYSTEMD_CONF_OPTS += --enable-firstboot
+else
+SYSTEMD_CONF_OPTS += --disable-firstboot
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK