package/gssdp: explicitly disable vapi
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 16:41:50 +0000 (09:41 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 15 Mar 2020 17:21:13 +0000 (18:21 +0100)
Currently, vapi support does not work with meson due to meson calling vapigen
directly instead of the vala wrapper. As such, when building typelib files for
gobject-introspection, vapigen fails to find the proper .gir files and fails
to build.

Explicitly disable vapi until a fix for vapi is made.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gssdp/gssdp.mk

index 4589517691d54111d2d606da1cdb0e94a7e103ae..071ad00109b23e49f7e210660be19fea74dc2919 100644 (file)
@@ -14,7 +14,8 @@ GSSDP_INSTALL_STAGING = YES
 GSSDP_DEPENDENCIES = host-pkgconf libglib2 libsoup
 GSSDP_CONF_OPTS = \
        -Dexamples=false \
-       -Dintrospection=false
+       -Dintrospection=false \
+       -Dvapi=false
 
 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
 GSSDP_DEPENDENCIES += libgtk3