lua-msgpack-native: new package v2
authorFrancois Perrad <fperrad@gmail.com>
Mon, 3 Sep 2012 20:58:37 +0000 (20:58 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 15 Nov 2012 11:39:12 +0000 (12:39 +0100)
[Peter: reformat Config.in to fit 80-col]
Signed-off-by: Wojciech M. Zabolotny <wzab01@gmail.com>
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/lua-msgpack-native/Config.in [new file with mode: 0644]
package/lua-msgpack-native/lua-msgpack-native.mk [new file with mode: 0644]

index 074e9dfdeb77df23f72585d2b15f0642a5b9263b..5d9783ad591b26594bf054422504d75cc25baaa8 100644 (file)
@@ -277,6 +277,7 @@ source "package/luacjson/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luafilesystem/Config.in"
 source "package/luasocket/Config.in"
+source "package/lua-msgpack-native/Config.in"
 source "package/rings/Config.in"
 source "package/wsapi/Config.in"
 source "package/xavante/Config.in"
diff --git a/package/lua-msgpack-native/Config.in b/package/lua-msgpack-native/Config.in
new file mode 100644 (file)
index 0000000..8894ee5
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_MSGPACK_NATIVE
+       bool "lua-msgpack-native"
+       help
+         This is a native, C language implementation of msgpack
+         (http://msgpack.org) library/protocol for Lua language
+
+         https://github.com/kengonakajima/lua-msgpack-native
diff --git a/package/lua-msgpack-native/lua-msgpack-native.mk b/package/lua-msgpack-native/lua-msgpack-native.mk
new file mode 100644 (file)
index 0000000..5d8cd2d
--- /dev/null
@@ -0,0 +1,29 @@
+#############################################################
+#
+# lua-msgpack-native
+#
+#############################################################
+LUA_MSGPACK_NATIVE_VERSION = 41cce91ab6
+LUA_MSGPACK_NATIVE_SITE = git://github.com/kengonakajima/lua-msgpack-native.git
+LUA_MSGPACK_NATIVE_METHOD = git
+LUA_MSGPACK_NATIVE_DEPENDENCIES = lua
+LUA_MSGPACK_NATIVE_LICENSE = Apache-2.0
+LUA_MSGPACK_NATIVE_LICENSE_FILES = LICENSE.txt
+
+define LUA_MSGPACK_NATIVE_BUILD_CMDS
+       $(TARGET_CC) $(TARGET_CFLAGS) -fPIC -shared -o $(@D)/msgpack.so $(@D)/mp.c
+endef
+
+define LUA_MSGPACK_NATIVE_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/msgpack.so $(TARGET_DIR)/usr/lib/lua/msgpack.so
+endef
+
+define LUA_MSGPACK_NATIVE_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/usr/lib/lua/msgpack.so
+endef
+
+define LUA_MSGPACK_NATIVE_CLEAN_CMDS
+       rm -f $(@D)/msgpack.so
+endef
+
+$(eval $(generic-package))