package/pamtester: new package
authorCarlos Santos <casantos@datacom.com.br>
Mon, 4 Feb 2019 14:33:55 +0000 (08:33 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Feb 2019 17:05:01 +0000 (18:05 +0100)
Utility for testing pluggable authentication modules (PAM) facility.

While specifically designed to help PAM module authors to test their
modules, that might also be handy for system administrators interested
in building a centralised authentication system using common standards
such as NIS, SASL and LDAP.

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Peter: drop spelling fix patch]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/pamtester/Config.in [new file with mode: 0644]
package/pamtester/pamtester.hash [new file with mode: 0644]
package/pamtester/pamtester.mk [new file with mode: 0644]

index a04ab4553336c33f2d07f29ed07ae74e31d24bfe..59e1f32ba9878d688ae7b43c0910131d46e8fe85 100644 (file)
@@ -426,6 +426,7 @@ F:  package/intel-microcode/
 F:     package/libpam-radius-auth/
 F:     package/libpam-tacplus/
 F:     package/modem-manager/
+F:     package/pamtester/
 F:     package/pcm-tools/
 F:     package/perl-file-util/
 F:     package/skeleton-custom/
index 9082ed99563e28db042334a92b86dd2ae5f65468..bca61f14ed9b860f103907a4935439bf9531cebf 100644 (file)
@@ -2163,6 +2163,7 @@ menu "System tools"
        source "package/numactl/Config.in"
        source "package/nut/Config.in"
        source "package/openvmtools/Config.in"
+       source "package/pamtester/Config.in"
        source "package/polkit/Config.in"
        source "package/powerpc-utils/Config.in"
        source "package/procps-ng/Config.in"
diff --git a/package/pamtester/Config.in b/package/pamtester/Config.in
new file mode 100644 (file)
index 0000000..19b76d3
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_PAMTESTER
+       bool "pamtester"
+       depends on BR2_PACKAGE_LINUX_PAM
+       help
+         A tiny utility for testing pluggable authentication modules
+         (PAM) facility. While specifically designed to help PAM module
+         authors to test their modules, that might also be handy for
+         system administrators interested in building a centralised
+         authentication system using common standards such as NIS, SASL
+         and LDAP.
+
+         http://pamtester.sourceforge.net/
+
+comment "pamtester depends on linux-pam"
+       depends on !BR2_PACKAGE_LINUX_PAM
diff --git a/package/pamtester/pamtester.hash b/package/pamtester/pamtester.hash
new file mode 100644 (file)
index 0000000..17497e3
--- /dev/null
@@ -0,0 +1,3 @@
+# from https://sourceforge.net/projects/pamtester/files/pamtester/0.1.2/
+sha1   33bcc610d7f208b50a0a23c144bdbd1e2cae4ac6  pamtester-0.1.2.tar.gz
+sha256 1e3922a8ab0907c1f3bcc3e00005ef88930e50d0890f40a6a39f5f83b05f05cc LICENSE
diff --git a/package/pamtester/pamtester.mk b/package/pamtester/pamtester.mk
new file mode 100644 (file)
index 0000000..b09e4d1
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# pamtester
+#
+################################################################################
+
+PAMTESTER_VERSION = 0.1.2
+PAMTESTER_SITE = https://download.sourceforge.net/project/pamtester/pamtester/$(PAMTESTER_VERSION)
+PAMTESTER_DEPENDENCIES = linux-pam
+PAMTESTER_LICENSE = BSD-3-Clause
+PAMTESTER_LICENSE_FILES = LICENSE
+
+$(eval $(autotools-package))