hiawatha: bump to version 10.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Dec 2015 15:03:08 +0000 (12:03 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Dec 2015 16:03:50 +0000 (17:03 +0100)
Now uses the new mbedtls package, and requires zlib.
Rename the SSL option description to TLS, but keep the same symbol
name to avoid pointless legacy.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/hiawatha/Config.in
package/hiawatha/hiawatha.hash
package/hiawatha/hiawatha.mk

index 53336972ada9ea159825d76a48af42dfc478043f..68e47fde87cde0a3e4d6f405e6bc98c6f0b22729 100644 (file)
@@ -1,12 +1,14 @@
-comment "hiawatha needs a toolchain w/ threads"
+comment "hiawatha needs a toolchain w/ threads, dynamic library"
        depends on BR2_USE_MMU
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
 
 config BR2_PACKAGE_HIAWATHA
        bool "hiawatha"
        # needs fork()
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_ZLIB
        help
          Hiawatha is a webserver for Unix and has been built with
          security in mind. This resulted in a highly secure
@@ -27,7 +29,7 @@ config BR2_PACKAGE_HIAWATHA
 if BR2_PACKAGE_HIAWATHA
 
 config BR2_PACKAGE_HIAWATHA_SSL
-       bool "hiawatha SSL support"
-       select BR2_PACKAGE_POLARSSL
+       bool "hiawatha TLS support"
+       select BR2_PACKAGE_MBEDTLS
 
 endif
index a9ac716de08177d43d6d8ba479c9fdf38dcffbba..af59e9f59d25160a1c5cb84077286a0de2e20f03 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 5d9cdec51c618bb3efab747030e593d9bd49dfaf3236254c8e0cb60715716dbf        hiawatha-9.2.tar.gz
+sha256 a39d1f771d818025538bd1231f42001bf29a1ebf55ce3d82afb7305cc251dd0e        hiawatha-10.0.tar.gz
index 91c972ddd748a85531a4bae7a12df44a702fab3f..411853bda85766b9fdec4bd96fce18c7ff7ef013 100644 (file)
@@ -4,16 +4,17 @@
 #
 ################################################################################
 
-HIAWATHA_VERSION = 9.2
+HIAWATHA_VERSION = 10.0
 HIAWATHA_SITE = http://www.hiawatha-webserver.org/files
+HIAWATHA_DEPENDENCIES = zlib
 HIAWATHA_LICENSE = GPLv2
 HIAWATHA_LICENSE_FILES = LICENSE
 
 ifeq ($(BR2_PACKAGE_HIAWATHA_SSL),y)
-HIAWATHA_CONF_OPTS += -DUSE_SYSTEM_POLARSSL=ON
-HIAWATHA_DEPENDENCIES += polarssl
+HIAWATHA_CONF_OPTS += -DUSE_SYSTEM_MBEDTLS=ON
+HIAWATHA_DEPENDENCIES += mbedtls
 else
-HIAWATHA_CONF_OPTS += -DENABLE_SSL=OFF
+HIAWATHA_CONF_OPTS += -DENABLE_TLS=OFF
 endif
 
 HIAWATHA_CONF_OPTS += \