package/tz: fix variable name
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 4 Jul 2017 06:56:38 +0000 (08:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 06:59:33 +0000 (08:59 +0200)
The tz package mixes its own variable with the one from the tzdata
package...

Fix the variable name in tz.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Alexandre BELLONI <alexandre.belloni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tz/tz.mk

index 4d1c8c4d614166a65b94c37d4d707a1501f0a3d7..6b1f9f4d24e1ff4646c6261658b2fbc92ecc045c 100644 (file)
@@ -26,13 +26,13 @@ define TZ_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/usr/share/zoneinfo/uclibc
        cp -a $(@D)/output/* $(TARGET_DIR)/usr/share/zoneinfo/uclibc
        if [ -n "$(TZ_LOCALTIME)" ]; then \
-               if [ ! -f $(TARGET_DIR)/usr/share/zoneinfo/uclibc/$(TZDATA_LOCALTIME) ]; then \
+               if [ ! -f $(TARGET_DIR)/usr/share/zoneinfo/uclibc/$(TZ_LOCALTIME) ]; then \
                        printf "Error: '%s' is not a valid timezone, check your BR2_TARGET_LOCALTIME setting\n" \
-                       "$(TZDATA_LOCALTIME)"; \
+                               "$(TZ_LOCALTIME)"; \
                        exit 1; \
                fi; \
                cd $(TARGET_DIR)/etc; \
-               ln -sf ../usr/share/zoneinfo/uclibc/$(TZDATA_LOCALTIME) TZ; \
+               ln -sf ../usr/share/zoneinfo/uclibc/$(TZ_LOCALTIME) TZ; \
        fi
 endef