samba: remove swat documentation when not needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 11:41:46 +0000 (13:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Jul 2010 20:18:56 +0000 (22:18 +0200)
When SWAT (the Web administration tool of Samba) is enabled, which is
the default when one enables samba in Buildroot, a lot of
documentation gets installed in /usr/swat (~15 MB). This patch fixes
this by removing the documentation when BR2_HAVE_DOCUMENTATION is not
set.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba/samba.mk

index 1c59070d4e9dd18447d79c0d4bb6dac9440da3ef..44f7fdeff1d20acdc8a9df13dbeb307726c39d48 100644 (file)
@@ -161,6 +161,17 @@ $(SAMBA_HOOK_POST_INSTALL):
        # remove unneeded
        rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_))
        rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_TXTTARGETS_))
+ifeq ($(BR2_PACKAGE_SAMBA_SWAT),y)
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
+       # Remove the documentation
+       rm -rf $(TARGET_DIR)/usr/swat/help/manpages
+       rm -rf $(TARGET_DIR)/usr/swat/help/Samba3*
+       rm -rf $(TARGET_DIR)/usr/swat/using_samba/
+       # Removing the welcome.html file will make swat default to
+       # welcome-no-samba-doc.html
+       rm -rf $(TARGET_DIR)/usr/swat/help/welcome.html
+endif
+endif
        # strip binaries
        $(STRIPCMD) $(STRIP_STRIP_ALL) $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_y))
        # install start/stop script