kvazaar: new package
authorAlexandre Esse <alexandre.esse.dev@gmail.com>
Fri, 16 Jun 2017 23:29:27 +0000 (01:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Jun 2017 20:03:47 +0000 (22:03 +0200)
Kvazaar is an open-source HEVC encoder licensed under LGPLv2.1.
This provides tools to encode raw video into HEVC stream.

website: http://ultravideo.cs.tut.fi/

Signed-off-by: Alexandre Esse <alexandre.esse.dev@gmail.com>
[Thomas: add --without-cryptopp to explicitly disable support for this
optional dependency, use SPDX license code, fix Config.in]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/kvazaar/Config.in [new file with mode: 0644]
package/kvazaar/kvazaar.hash [new file with mode: 0644]
package/kvazaar/kvazaar.mk [new file with mode: 0644]

index 6ade852ee3adb7aec88133c4ce7130a41bebda0c..f86a5dc278a9de98161b0951c2d2878e8ae74e9e 100644 (file)
@@ -64,6 +64,9 @@ F:    package/liblog4c-localtime/
 N:     Alexandre Belloni <alexandre.belloni@free-electrons.com>
 F:     package/tz/
 
+N:     Alexandre Esse <alexandre.esse.dev@gmail.com>
+F:     package/kvazaar/
+
 N:     Alistair Francis <alistair.francis@xilinx.com>
 F:     package/xen/
 
index c997e2a306706811f9e2570b38078eb91b791f24..aeb7430c89423265f9bb7a28c74bd3e455b56d9d 100644 (file)
@@ -1219,6 +1219,7 @@ endmenu
 
 menu "Multimedia"
        source "package/bitstream/Config.in"
+       source "package/kvazaar/Config.in"
        source "package/libaacs/Config.in"
        source "package/libamcodec/Config.in"
        source "package/libass/Config.in"
diff --git a/package/kvazaar/Config.in b/package/kvazaar/Config.in
new file mode 100644 (file)
index 0000000..3377145
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_KVAZAAR
+       bool "kvazaar"
+       help
+         An open-source HEVC encoder licensed under LGPLv2.1
+
+         https://github.com/ultravideo/kvazaar
diff --git a/package/kvazaar/kvazaar.hash b/package/kvazaar/kvazaar.hash
new file mode 100644 (file)
index 0000000..80f480b
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 8e382738a51004bfcfca4c832e8b41fe6a17f889f3c39151dc1c1a37261a3a6d  kvazaar-v1.1.0.tar.gz
diff --git a/package/kvazaar/kvazaar.mk b/package/kvazaar/kvazaar.mk
new file mode 100644 (file)
index 0000000..30b8bda
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# kvazaar
+#
+################################################################################
+
+KVAZAAR_VERSION = v1.1.0
+KVAZAAR_SITE = $(call github,ultravideo,kvazaar,$(KVAZAAR_VERSION))
+KVAZAAR_LICENSE = LGPL-2.1+
+KVAZAAR_LICENSE_FILES = COPYING
+KVAZAAR_AUTORECONF = YES
+KVAZAAR_INSTALL_STAGING = YES
+KVAZAAR_CONF_OPTS = --without-cryptopp
+
+$(eval $(autotools-package))