bash: fix static build
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 12 Aug 2013 13:15:45 +0000 (10:15 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Aug 2013 08:17:57 +0000 (10:17 +0200)
The static build needs some trickery, so make it happen. Fixes:
http://autobuild.buildroot.net/results/2b12868f8297a96d7abf7fcf526ca5eace73d66d/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bash/bash.mk

index d51e2037dd86529a50c0fa0e27d14aca0dc52ad9..efd2334ad0e768929fb2dd279c43467997ee2ac9 100644 (file)
@@ -16,6 +16,11 @@ BASH_CONF_ENV +=                       \
    bash_cv_func_sigsetjmp=present      \
    bash_cv_printf_a_format=yes
 
+# The static build needs some trickery
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+BASH_CONF_OPT += --enable-static-link --without-bash-malloc
+endif
+
 # Make sure we build after busybox so that /bin/sh links to bash
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 BASH_DEPENDENCIES += busybox