busybox: remove shadow passwords config tweaks
authorBaruch Siach <baruch@tkos.co.il>
Tue, 8 May 2018 15:05:18 +0000 (18:05 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 May 2018 20:58:40 +0000 (22:58 +0200)
These configuration tweaks were added for compatibility with Blackfin
toolchains that bundled a uClibc version without shadow passwords
support. Blackfin is gone, so this is no longer needed.

Cc: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/busybox/busybox.mk

index 7033c4304a946908badec455967c59e1557568dc..75fe7e137b973b0fccdf6b03724f38ee9357d64e 100644 (file)
@@ -148,14 +148,6 @@ define BUSYBOX_PREFER_STATIC
 endef
 endif
 
-# Disable shadow passwords support if unsupported by the C library
-ifeq ($(BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS),)
-define BUSYBOX_INTERNAL_SHADOW_PASSWORDS
-       $(call KCONFIG_ENABLE_OPT,CONFIG_USE_BB_PWD_GRP,$(BUSYBOX_BUILD_CONFIG))
-       $(call KCONFIG_ENABLE_OPT,CONFIG_USE_BB_SHADOW,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
-
 define BUSYBOX_INSTALL_UDHCPC_SCRIPT
        if grep -q CONFIG_UDHCPC=y $(@D)/.config; then \
                $(INSTALL) -m 0755 -D package/busybox/udhcpc.script \
@@ -273,7 +265,6 @@ define BUSYBOX_KCONFIG_FIXUP_CMDS
        $(BUSYBOX_SET_MDEV)
        $(BUSYBOX_SET_CRYPT_SHA)
        $(BUSYBOX_LINUX_PAM)
-       $(BUSYBOX_INTERNAL_SHADOW_PASSWORDS)
        $(BUSYBOX_SET_INIT)
        $(BUSYBOX_SET_WATCHDOG)
        $(BUSYBOX_SET_SELINUX)