package/runc: fix version output ldflags
authorChristian Stewart <christian@paral.in>
Wed, 16 Dec 2020 08:00:09 +0000 (00:00 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 30 Dec 2020 08:27:21 +0000 (09:27 +0100)
Fix the ldflags specifying the version info for "version" command.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/runc/runc.mk

index c559244e838c9dc620bc2476fbbf5aaf647a5f82..45fe1442adcba0ec0f5d56a1972063674f34d41b 100644 (file)
@@ -9,7 +9,7 @@ RUNC_SITE = $(call github,opencontainers,runc,v$(RUNC_VERSION))
 RUNC_LICENSE = Apache-2.0
 RUNC_LICENSE_FILES = LICENSE
 
-RUNC_LDFLAGS = -X main.gitCommit=$(RUNC_VERSION)
+RUNC_LDFLAGS = -X main.version=$(RUNC_VERSION)
 RUNC_TAGS = cgo static_build
 
 ifeq ($(BR2_PACKAGE_LIBAPPARMOR),y)