package/python-pillow: add lcms2 support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 22 May 2021 17:41:56 +0000 (19:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 May 2021 08:30:33 +0000 (10:30 +0200)
lcms2 is an optional dependency since version 2.3.0 and
https://github.com/python-pillow/Pillow/commit/6d9f34914021951bba42ffe5b6cd80147e7f538f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-pillow/python-pillow.mk

index f71fa156e2a51005346e60de5d80827f5636c6e4..3018758b4841b81ffb66ce2f1e85a8b6e9fded1f 100644 (file)
@@ -28,6 +28,13 @@ else
 PYTHON_PILLOW_BUILD_OPTS += --disable-jpeg
 endif
 
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+PYTHON_PILLOW_DEPENDENCIES += lcms2
+PYTHON_PILLOW_BUILD_OPTS += --enable-lcms
+else
+PYTHON_PILLOW_BUILD_OPTS += --disable-lcms
+endif
+
 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
 PYTHON_PILLOW_DEPENDENCIES += openjpeg
 PYTHON_PILLOW_BUILD_OPTS += --enable-jpeg2000