qt5canvas3d: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:31:58 +0000 (08:31 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:03 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `canvas3d' from the staging directory to
the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5canvas3d/qt5canvas3d.mk

index 13e233f2379f17507126ff4489fb557facfdee4b..3cdf59a1572c37033a055ebcdb8342d65e0bda38 100644 (file)
@@ -26,8 +26,15 @@ define QT5CANVAS3D_INSTALL_STAGING_CMDS
        $(QT5_LA_PRL_FILES_FIXUP)
 endef
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5CANVAS3D_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/canvas3d $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
 define QT5CANVAS3D_INSTALL_TARGET_CMDS
        cp -dpfr $(STAGING_DIR)/usr/qml/QtCanvas3D $(TARGET_DIR)/usr/qml/
+       $(QT5CANVAS3D_INSTALL_TARGET_EXAMPLES)
 endef
 
 $(eval $(generic-package))