libpjsip: fix ssl support
authorAdam Duskett <aduskett@gmail.com>
Tue, 14 Nov 2017 14:42:03 +0000 (09:42 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Nov 2017 22:02:11 +0000 (23:02 +0100)
Currently, ssl support is implicitely disabled in the initial configure
options. This overrides the check for openssl below.

libpjsip is also currently only compatible with libopenssl. Change
the check to LIBOPENSSL instead of openssl, and depend on libopenssl.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpjsip/libpjsip.mk

index 6f3f9e3f1a7171e39adec6401d42b258b6cd65c8..eca6d8f1ee5955a4440a7c0b810d3d92f95d58b0 100644 (file)
@@ -50,7 +50,6 @@ LIBPJSIP_CONF_OPTS = \
        --disable-openh264 \
        --disable-libyuv \
        --disable-ipp \
-       --disable-ssl \
        --disable-silk \
        --with-external-srtp
 
@@ -59,8 +58,8 @@ LIBPJSIP_CONF_OPTS = \
 # so we want to use it.
 LIBPJSIP_CONF_OPTS += --enable-epoll
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-LIBPJSIP_DEPENDENCIES += openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+LIBPJSIP_DEPENDENCIES += libopenssl
 LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
 else
 LIBPJSIP_CONF_OPTS += --disable-ssl