package/botan: add optional dependency to sqlite
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 18 Aug 2018 23:30:51 +0000 (01:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 21:32:53 +0000 (23:32 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index e25bf5b52f29e4db67e37c9a6d649d249d8e308e..984ecdc039f7c9d37ab523627bbda74076633fd1 100644 (file)
@@ -55,6 +55,11 @@ BOTAN_DEPENDENCIES += openssl
 BOTAN_CONF_OPTS += --with-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_SQLITE),y)
+BOTAN_DEPENDENCIES += sqlite
+BOTAN_CONF_OPTS += --with-sqlite
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 BOTAN_DEPENDENCIES += zlib
 BOTAN_CONF_OPTS += --with-zlib