lttng-tools: add missing dependency on util-linux for libuuid
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Jul 2013 22:04:48 +0000 (00:04 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Jul 2013 09:49:57 +0000 (11:49 +0200)
Fixes:
http://autobuild.buildroot.org/results/76a/76a91bd139a93f63e17732c9a933664e8e5d3fe1/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lttng-tools/Config.in
package/lttng-tools/lttng-tools.mk

index 67734753c6f4c8915996ce30d24dcd6764b063fd..c196e4b637d81a8f021bffc489959ec035cdd062 100644 (file)
@@ -2,9 +2,12 @@ config BR2_PACKAGE_LTTNG_TOOLS
        bool "lttng-tools"
        select BR2_PACKAGE_LIBURCU
        select BR2_PACKAGE_POPT
+       select BR2_PACKAGE_UTIL_LINUX
+       select BR2_PACKAGE_UTIL_LINUX_LIBUUID
        # liburcu only works on some architectures and requires thread support
        depends on BR2_arm || BR2_armeb || BR2_i386 || BR2_powerpc || BR2_x86_64
        depends on BR2_LARGEFILE
+       depends on BR2_USE_WCHAR # util-linux
        depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          Userspace utilities for the LTTng 2.0 tracing
@@ -24,6 +27,6 @@ config BR2_PACKAGE_LTTNG_TOOLS
 
          http://lttng.org
 
-comment "lttng-tools needs LARGEFILE and threads support"
-       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
-
+comment "lttng-tools needs LARGEFILE, threads and wchar support"
+       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_USE_WCHAR
index 2e9f9361322e8218ea57a87f0b8fb5cf65ecb417..d48bc0a905d3881c09fad64e93c3055f19345c87 100644 (file)
@@ -18,7 +18,7 @@ LTTNG_TOOLS_LICENSE_FILES = LICENSE
 # Since the 2.1.0 release, lttng-tools depends on flex and bison,
 # but they are not added to the dependency list since they are
 # already Buildroot dependencies.
-LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace
+LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace util-linux
 
 LTTNG_AUTORECONF = YES