package: get rid of redundant malloc related configure presets
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 Dec 2009 18:55:42 +0000 (19:55 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 Dec 2009 18:58:45 +0000 (19:58 +0100)
Those are already in TARGET_CONFIGURE_ARGS. Also get rid of unused
BR2_AC_CV_FUNC_MALLOC_0_NONNULL variable.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
21 files changed:
package/Makefile.in
package/atk/atk.mk
package/avahi/avahi.mk
package/bootutils/bootutils.mk
package/cairo/cairo.mk
package/coreutils/coreutils.mk
package/diffutils/diffutils.mk
package/fbdump/fbdump.mk
package/games/gnuchess/gnuchess.mk
package/gettext/gettext.mk
package/gtk2-engines/gtk2-engines.mk
package/iperf/iperf.mk
package/java/classpath/classpath.mk
package/java/jamvm/jamvm.mk
package/libglib2/libglib2.mk
package/libgtk2/libgtk2.mk
package/libpng/libpng.mk
package/lvm2/lvm2.mk
package/pango/pango.mk
package/psmisc/psmisc.mk
package/x11r7/xlib_libX11/xlib_libX11.mk

index b5a7a8edab08bb354eff1bf544efb448cf891f83..7c009bbe00a74a910c1c902f4e8f98d6992ae375 100644 (file)
@@ -303,20 +303,6 @@ else
 BR2_AC_CV_C_BIGENDIAN=ac_cv_c_bigendian=no
 endif
 
-# XXX: FIXME: We would need to grab MALLOC_GLIBC_COMPAT from the uClibc.config
-# Including it doesn't seem wise, grepping is ugly.. Suggestions?
-# Does malloc return live pointer for malloc(0) ?
-ifeq ($(MALLOC_GLIBC_COMPAT),y)
-BR2_AC_CV_FUNC_MALLOC_0_NONNULL=ac_cv_func_malloc_0_nonnull=yes \
-                               gl_cv_func_malloc_0_nonnull=yes \
-                               ac_cv_func_realloc_0_nonnull=yes
-else
-BR2_AC_CV_FUNC_MALLOC_0_NONNULL=ac_cv_func_malloc_0_nonnull=no \
-                               gl_cv_func_malloc_0_nonnull=no \
-                               ac_cv_func_realloc_0_nonnull=no
-endif
-
-
 TARGET_CONFIGURE_ARGS= \
        $(BR2_AC_CV_TRAP_CHECK) \
        ac_cv_func_mmap_fixed_mapped=yes \
index df8039ea4a2ddf1c31c2352f980afb72d77fcaef..93b9e9e4e7a8c368e9f0364fcc080635b7489687 100644 (file)
@@ -28,8 +28,6 @@ ATK_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes \
                ac_cv_func_getdelim=yes ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no utils_cv_func_mkdir_trailing_slash_bug=no \
                ac_cv_func_memcmp_working=yes ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no gl_cv_func_working_readdir=yes \
                jm_ac_cv_func_link_follows_symlink=no utils_cv_localtime_cache=no \
                ac_cv_struct_st_mtim_nsec=no gl_cv_func_tzset_clobber=no \
index 7c463b6ddfcb29bf53f582b2879d9ab6e892a7ab..0c9d11e90114a2921d64b688046afdf35012abb3 100644 (file)
@@ -46,12 +46,6 @@ AVAHI_CONF_ENV = ac_cv_func_strtod=yes \
                ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                am_cv_func_working_getline=yes \
                gl_cv_func_working_readdir=yes \
index 3c4459e030c591a730edade1b8460792646f1320..fda0a4d23cd981612a311d1296de3a8fe9f82ad7 100644 (file)
@@ -6,8 +6,6 @@
 BOOTUTILS_VERSION = 0.0.9
 BOOTUTILS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/bootutils
 
-BOOTUTILS_CONF_ENV = ac_cv_func_malloc_0_nonnull=yes
-
 BOOTUTILS_CONF_OPT = --prefix=/ --exec-prefix=/
 
 BOOTUTILS_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
index 2f3687f40b64fb28460318feb2292727a625cfa8..e160bf92c4ca52546376816d9de1b7d40958b50c 100644 (file)
@@ -26,10 +26,7 @@ CAIRO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_strerror_r_char_p=no jm_cv_func_svid_putenv=yes \
                ac_cv_func_getcwd_null=yes ac_cv_func_getdelim=yes \
                ac_cv_func_mkstemp=yes utils_cv_func_mkstemp_limitations=no \
-               utils_cv_func_mkdir_trailing_slash_bug=no ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes jm_cv_func_gettimeofday_clobber=no \
+               utils_cv_func_mkdir_trailing_slash_bug=no jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes jm_ac_cv_func_link_follows_symlink=no \
                utils_cv_localtime_cache=no ac_cv_struct_st_mtim_nsec=no \
                gl_cv_func_tzset_clobber=no gl_cv_func_getcwd_null=yes \
index 0dcb62b675ec7cecf044a0758f03a75b1ab92090..85a5491b6b27b5de20f4605ee2dc5dc1766b2fd6 100644 (file)
@@ -63,12 +63,6 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
                gl_cv_func_rename_dest_exists_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                am_cv_func_working_getline=yes \
                gl_cv_func_working_readdir=yes \
index 773913bf30853db3340789ce916ee29d4a7774f1..fe1bab8418e79dafb67bc5bada102154e466c676 100644 (file)
@@ -55,12 +55,6 @@ $(DIFFUTILS_DIR)/.configured: $(DIFFUTILS_DIR)/.unpacked
                ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                am_cv_func_working_getline=yes \
                gl_cv_func_working_readdir=yes \
index 9dcb7cd0faa3c76e6b6d8279612f0644f53bb9bf..521b0fdebb6c442433243a0dd9db3ffd84ff7cac 100644 (file)
@@ -7,8 +7,6 @@ FBDUMP_VERSION:=0.4.2
 FBDUMP_SOURCE:=fbdump-$(FBDUMP_VERSION).tar.gz
 FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
 FBDUMP_AUTORECONF = NO
-FBDUMP_CONF_ENV = ac_cv_func_malloc_0_nonnull=yes
-FBDUMP_INSTALL_TARGET = YES
 
 $(eval $(call AUTOTARGETS,package,fbdump))
 
index 921d0fdc85b9a75243fc79708365cc98c8976adb..d5a8dd65acea07b0c2504d352aa1783cfffc390f 100644 (file)
@@ -6,10 +6,6 @@
 GNUCHESS_VERSION = 5.07
 GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
 GNUCHESS_SITE = $(BR2_GNU_MIRROR)/chess
-GNUCHESS_INSTALL_STAGING = NO
-GNUCHESS_INSTALL_TARGET = YES
-
-GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
 
 $(eval $(call AUTOTARGETS,package/games,gnuchess))
 
index fb83d5bae212ec81d2e0dc6fe0ac0409cf54de02..a0955c159780bbc69e932d8a42fe923cf2bb112a 100644 (file)
@@ -67,12 +67,6 @@ $(GETTEXT_DIR)/.configured: $(GETTEXT_DIR)/.unpacked
                ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes \
                jm_ac_cv_func_link_follows_symlink=no \
index 2ffce75f6a12194d2c71941f201838614b678f51..4c7776e656f946b913f48341ab7ae67d5aef2b61 100644 (file)
@@ -46,12 +46,6 @@ GTK2_ENGINES_BUILD_ENV= \
                ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes \
                jm_ac_cv_func_link_follows_symlink=no \
index 27c8e53383c52cfc2566daaca0121b4335c10708..d18d7e5b360518401da7d56365a9c69e68247302 100644 (file)
@@ -8,9 +8,6 @@ IPERF_VERSION:=2.0.3
 IPERF_SOURCE:=iperf-$(IPERF_VERSION).tar.gz
 IPERF_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/iperf
 IPERF_AUTORECONF:=NO
-IPERF_INSTALL_STAGING:=NO
-IPERF_INSTALL_TARGET:=YES
-IPERF_CONF_ENV:=ac_cv_func_malloc_0_nonnull=yes
-IPERF_CONF_OPT:=--disable-dependency-tracking --disable-web100 $(DISABLE_IPV6)
+IPERF_CONF_OPT:=--disable-dependency-tracking --disable-web100
 
 $(eval $(call AUTOTARGETS,package,iperf))
index 3cd21eb30642d1aa8f3fe75e272ff7220437377d..c63837b7b19c0b72157e29b3f44a29476c29cbc2 100644 (file)
@@ -30,9 +30,7 @@ CLASSPATH_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_getcwd_null=yes ac_cv_func_getdelim=yes \
                ac_cv_func_mkstemp=yes utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_have_decl_malloc=yes gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes jm_cv_func_gettimeofday_clobber=no \
+               jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes jm_ac_cv_func_link_follows_symlink=no \
                utils_cv_localtime_cache=no ac_cv_struct_st_mtim_nsec=no \
                gl_cv_func_tzset_clobber=no gl_cv_func_getcwd_null=yes \
index bd66e42b200c4450fae4256c5abc054cdc18820b..65ba096c7db7439571c133b7c5af39683e7fbae4 100644 (file)
@@ -28,9 +28,7 @@ JAMVM_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_getcwd_null=yes ac_cv_func_getdelim=yes \
                ac_cv_func_mkstemp=yes utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_have_decl_malloc=yes gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes jm_cv_func_gettimeofday_clobber=no \
+               jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes jm_ac_cv_func_link_follows_symlink=no \
                utils_cv_localtime_cache=no ac_cv_struct_st_mtim_nsec=no \
                gl_cv_func_tzset_clobber=no gl_cv_func_getcwd_null=yes \
index 71008002d0706866fe8337b1811b14b311c5b668..2d02b9b56e6fc028550c4073efdac0fec95e1840 100644 (file)
@@ -33,9 +33,7 @@ LIBGLIB2_CONF_ENV =   \
                ac_cv_func_getcwd_null=yes ac_cv_func_getdelim=yes \
                ac_cv_func_mkstemp=yes utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_have_decl_malloc=yes gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes jm_cv_func_gettimeofday_clobber=no \
+               jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes jm_ac_cv_func_link_follows_symlink=no \
                utils_cv_localtime_cache=no ac_cv_struct_st_mtim_nsec=no \
                gl_cv_func_tzset_clobber=no gl_cv_func_getcwd_null=yes \
index 0855fbf60e4b2bbb298b22b26bdb790e60052ba9..83eab38d3e0bb074b2a1e0de9c8eff14e703cb3e 100644 (file)
@@ -45,12 +45,6 @@ LIBGTK2_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_mkstemp=yes \
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
-               ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes \
                jm_ac_cv_func_link_follows_symlink=no \
index f49a9a50f224fbbf25ee65e2e7c7eda0cd6ea5ee..3cb03a6f96627d432b423ea2b780a51174d08e5c 100644 (file)
@@ -8,13 +8,6 @@ LIBPNG_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/li
 LIBPNG_SOURCE = libpng-$(LIBPNG_VERSION).tar.bz2
 LIBPNG_LIBTOOL_PATCH = NO
 LIBPNG_INSTALL_STAGING = YES
-LIBPNG_INSTALL_TARGET = YES
-LIBPNG_CONF_ENV = \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes
 LIBPNG_CONF_OPT = --without-libpng-compat
 LIBPNG_DEPENDENCIES = host-pkgconfig zlib
 
index f3802a41e184a350b35fa7cc50d0953dfc39d546..d190be2f039e1cf91ee91317705091e1d18f0124 100644 (file)
@@ -61,11 +61,6 @@ $(LVM2_DIR)/.configured: $(LVM2_DIR)/.unpacked
        (cd $(LVM2_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_ARGS) \
-               ac_cv_have_decl_malloc=yes \
-               gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes \
                ./configure $(QUIET) \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
index 3d4b7a0cb5b7fe33684cc0f316ec8268a731a189..f7bf0aa02336d0e976e5980d48f8309df02a8008 100644 (file)
@@ -26,10 +26,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_cv_func_strerror_r_char_p=no jm_cv_func_svid_putenv=yes \
                ac_cv_func_getcwd_null=yes ac_cv_func_getdelim=yes \
                ac_cv_func_mkstemp=yes utils_cv_func_mkstemp_limitations=no \
-               utils_cv_func_mkdir_trailing_slash_bug=no ac_cv_func_memcmp_working=yes \
-               ac_cv_have_decl_malloc=yes gl_cv_func_malloc_0_nonnull=yes \
-               ac_cv_func_malloc_0_nonnull=yes ac_cv_func_calloc_0_nonnull=yes \
-               ac_cv_func_realloc_0_nonnull=yes jm_cv_func_gettimeofday_clobber=no \
+               utils_cv_func_mkdir_trailing_slash_bug=no jm_cv_func_gettimeofday_clobber=no \
                gl_cv_func_working_readdir=yes jm_ac_cv_func_link_follows_symlink=no \
                utils_cv_localtime_cache=no ac_cv_struct_st_mtim_nsec=no \
                gl_cv_func_tzset_clobber=no gl_cv_func_getcwd_null=yes \
index 9276b0845533e0dcb207d75f4ae95c89a77db680..e04923d7554626a6538c860528def8d48c4ca2aa 100644 (file)
@@ -7,11 +7,6 @@ PSMISC_VERSION:=22.8
 PSMISC_SOURCE:=psmisc-$(PSMISC_VERSION).tar.gz
 PSMISC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/psmisc
 PSMISC_AUTORECONF:=NO
-PSMISC_INSTALL_STAGING:=NO
-PSMISC_INSTALL_TARGET:=YES
-PSMISC_CONF_ENV:=ac_cv_func_malloc_0_nonnull=yes \
-                ac_cv_func_realloc_0_nonnull=yes
-PSMISC_CONF_OPT:= $(DISABLE_IPV6)
 PSMISC_DEPENDENCIES:=ncurses
 
 ifeq ($(BR2_ENABLE_LOCALE),y)
index 270e5ece4061cb910d227040ba54fb31d59097fc..e2f7e9a6db0a6ab5b8bb20a0d1b6f71a741fddc8 100644 (file)
@@ -10,7 +10,6 @@ XLIB_LIBX11_SITE = http://xorg.freedesktop.org/releases/individual/lib
 XLIB_LIBX11_AUTORECONF = YES
 XLIB_LIBX11_INSTALL_STAGING = YES
 XLIB_LIBX11_DEPENDENCIES = libxcb xutil_util-macros xlib_xtrans xlib_libXau xlib_libXdmcp xproto_kbproto xproto_xproto xproto_xextproto xproto_inputproto xproto_xf86bigfontproto xproto_bigreqsproto xproto_xcmiscproto
-XLIB_LIBX11_CONF_ENV = ac_cv_func_mmap_fixed_mapped=yes
 XLIB_LIBX11_CONF_OPT = --disable-malloc0returnsnull --with-xcb --enable-shared --disable-static --with-keysymdef=$(STAGING_DIR)/usr/include/X11/keysymdef.h
 
 $(eval $(call AUTOTARGETS,package/x11r7,xlib_libX11))