infra: remove incorrect default for FOO_DIR_PREFIX
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 7 Nov 2013 16:26:52 +0000 (17:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 10 Nov 2013 23:14:36 +0000 (00:14 +0100)
Variable FOO_DIR_PREFIX is populated from pkgparentdir by the various
package infrastructures. However, if that would be empty (which in fact is
the case for the linux package), FOO_DIR_PREFIX would be set to
'$(TOP_SRCDIR)/package'.
Not only does this make no sense (LINUX_DIR_PREFIX becomes /package/linux,
and for all other packages pkgparentdir is not-empty anyway), but it is also
using a non-existing variable TOP_SRCDIR.
This patch therefore removes the incorrect default.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-generic.mk

index 80b38a5808c2f2e2e41aff4933ef6290ed1b86ed..3b6bc76512d5f570ca369bdc279e6ac924de5755 100644 (file)
@@ -314,7 +314,7 @@ $(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix
 $(2)_INSTALL_STAGING           ?= NO
 $(2)_INSTALL_IMAGES            ?= NO
 $(2)_INSTALL_TARGET            ?= YES
-$(2)_DIR_PREFIX                        = $(if $(4),$(4),$(TOP_SRCDIR)/package)
+$(2)_DIR_PREFIX                        = $(4)
 
 # define sub-target stamps
 $(2)_TARGET_INSTALL_TARGET =   $$($(2)_DIR)/.stamp_target_installed