Revert "package/weston: libxkbcommon is optional"
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 9 Jun 2014 12:15:39 +0000 (14:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Jun 2014 12:28:13 +0000 (14:28 +0200)
This reverts commit cf1c2eb19d3eeddca04013cfa7b2107530abf054.

xkbcommon is still needed for the clients. There's no point in disabling
the clients, or weston is unusable (as packaged in Buildroot.)

Fixes:

  http://autobuild.buildroot.org/results/4e9/4e996c65f5b33d4518b0596d9c7076083d491a52/

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index 96ebdf1686fc9c27eeaca658c49d9474dc1b6eb5..aaef405e0fe489904c082c46d25337e870527c31 100644 (file)
@@ -5,6 +5,7 @@ comment "weston needs udev and a toolchain w/ threads, headers >= 3.0"
 config BR2_PACKAGE_WESTON
        bool "weston"
        select BR2_PACKAGE_WAYLAND
+       select BR2_PACKAGE_LIBXKBCOMMON
        select BR2_PACKAGE_CAIRO
        select BR2_PACKAGE_CAIRO_PNG
        select BR2_PACKAGE_LIBPNG
@@ -28,16 +29,6 @@ config BR2_PACKAGE_WESTON
 
 if BR2_PACKAGE_WESTON
 
-config BR2_PACKAGE_WESTON_HW_KBD
-       bool "enable keyboard support"
-       default y
-       select BR2_PACKAGE_LIBXKBCOMMON
-       help
-         Say 'y' here if you plan on using a keyboard.
-
-         Only say 'n' if you're going to use a virtual keyboard or any other
-         input method.
-
 # Helper to make sure at least one compositor is selected.
 config BR2_PACKAGE_WESTON_HAS_COMPOSITOR
        bool
index 325cfc75120c241f317006f34183871e11a931ba..ed0707b40e427c25e9d828115c8ebe76cc34b327 100644 (file)
@@ -10,7 +10,7 @@ WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
 WESTON_LICENSE = MIT
 WESTON_LICENSE_FILES = COPYING
 
-WESTON_DEPENDENCIES = host-pkgconf wayland pixman libpng \
+WESTON_DEPENDENCIES = host-pkgconf wayland libxkbcommon pixman libpng \
        jpeg mtdev udev cairo
 
 WESTON_CONF_OPT = \
@@ -25,13 +25,6 @@ WESTON_CONF_OPT = \
        --disable-weston-launch \
        --disable-colord
 
-ifeq ($(BR2_PACKAGE_WESTON_HW_KBD),y)
-WESTON_DEPENDENCIES += libxkbcommon
-WESTON_CONF_OPT += --enable-xkbcommon
-else
-WESTON_CONF_OPT += --disable-xkbcommon
-endif
-
 ifeq ($(BR2_PACKAGE_LIBINPUT),y)
 WESTON_DEPENDENCIES += libinput
 WESTON_CONF_OPT += --enable-libinput-backend