projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
879058a
)
pkg-generic.mk: handle packages under toolchain
author
Peter Korsgaard
<peter@korsgaard.com>
Mon, 16 Dec 2013 14:58:36 +0000
(15:58 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Mon, 16 Dec 2013 14:58:36 +0000
(15:58 +0100)
E.G. for toolchain-buildroot / toolchain-external. Now these packages are
correctly handled by make source / external-deps.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-generic.mk
patch
|
blob
|
history
diff --git
a/package/pkg-generic.mk
b/package/pkg-generic.mk
index 1fce71b6333cca26d8f8feda49be86531a56a920..45b808a6953848eef2eb394ae5db8f7a1ce4889c 100644
(file)
--- a/
package/pkg-generic.mk
+++ b/
package/pkg-generic.mk
@@
-509,6
+509,8
@@
ifeq ($(1),linux)
$(2)_KCONFIG_VAR = BR2_LINUX_KERNEL
else ifeq ($(4),boot/)
$(2)_KCONFIG_VAR = BR2_TARGET_$(2)
+else ifeq ($(4),toolchain/)
+$(2)_KCONFIG_VAR = BR2_$(2)
else
$(2)_KCONFIG_VAR = BR2_PACKAGE_$(2)
endif