qt5base: add support for fontconfig, png, jpeg, gif
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Mar 2013 09:29:36 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:08:29 +0000 (22:08 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index 0af5df642c58087ff31f147edd3bfcdb80d5e2df..8b0291b54b174a5e589c15d231b78530365725d3 100644 (file)
@@ -104,6 +104,32 @@ config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
        help
          This option enables the Qt5PrintSupport
 
+config BR2_PACKAGE_QT5BASE_FONTCONFIG
+       bool "fontconfig support"
+       select BR2_PACKAGE_FONTCONFIG
+       help
+         This option enables Fontconfig and Freetype support using
+         the system fontconfig and freetype2 libraries.
+
+config BR2_PACKAGE_QT5BASE_GIF
+       bool "GIF support"
+       help
+         This compiles and installs the plugin for GIF reading support.
+
+config BR2_PACKAGE_QT5BASE_JPEG
+       bool "JPEG support"
+       select BR2_PACKAGE_JPEG
+       help
+         This option enables JPEG support using the system libjpeg
+         library.
+
+config BR2_PACKAGE_QT5BASE_PNG
+       bool "PNG support"
+       select BR2_PACKAGE_LIBPNG
+       help
+         This option enables PNG support using the system libpng
+         library.
+
 endif
 
 endif
index 700bc67b8cebaf9d814609c1b63fef3fb000571e..65fe451e0250402460cda3acb6768d8c306763c2 100644 (file)
@@ -26,10 +26,6 @@ QT5BASE_CONFIGURE_OPTS += \
        -no-nis \
        -no-libudev \
        -no-iconv \
-       -no-fontconfig \
-       -no-gif \
-       -no-libpng \
-       -no-libjpeg \
        -no-icu \
        -no-dbus \
        -no-gstreamer \
@@ -89,6 +85,14 @@ endif
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_OPENSSL),openssl)
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),-fontconfig,-no-fontconfig)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),fontconfig)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_GIF),,-no-gif)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_JPEG),-system-libjpeg,-no-libjpeg)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_JPEG),jpeg)
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_PNG),-system-libpng,-no-libpng)
+QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_PNG),libpng)
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network