package/qt5wayland: examples needs opengl with qt latest
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 2 Jun 2019 20:07:34 +0000 (22:07 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 13 Jul 2019 20:46:07 +0000 (22:46 +0200)
WIth Qt latest, if opengl is not enabled, qt5wayland examples won't be
built:
make[3]: Entering directory `/home/dawncrow/buildroot-test/scripts/instance-0/output/build/qt5wayland-5.12.2/examples/wayland'
Some of the required modules (qtConfig(opengl)) are not available.
Skipped.
make[3]: Leaving directory `/home/dawncrow/buildroot-test/scripts/instance-0/output/build/qt5wayland-5.12.2/examples/wayland'

And build will fail on:
cp: cannot stat '/home/dawncrow/buildroot-test/scripts/instance-0/output/host/sparc64-buildroot-linux-gnu/sysroot/usr/lib/qt/examples/wayland': No such file or directory

Fixes:
 - http://autobuild.buildroot.org/results/902322ca156c14044d4ce53ab2c77f30dd854c98

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qt5/qt5wayland/qt5wayland.mk

index 449640c88149820b13855a7ebfd2b1b60d9be5e1..0bda596f3b638b3d51207aa25a1bb37d51ac3f56 100644 (file)
@@ -60,10 +60,18 @@ endif
 endif
 
 ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
+ifeq ($(BR2_PACKAGE_QT5BASE_OPENGL),y)
 define QT5WAYLAND_INSTALL_TARGET_EXAMPLES
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/wayland $(TARGET_DIR)/usr/lib/qt/examples/
 endef
 endif
+else
+define QT5WAYLAND_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/wayland $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+endif
 
 define QT5WAYLAND_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5WaylandClient.so* $(TARGET_DIR)/usr/lib