package/webkitgtk: add optional systemd dependency
authorPeter Seiderer <ps.report@gmx.net>
Mon, 9 Nov 2020 23:13:56 +0000 (00:13 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2020 20:25:23 +0000 (21:25 +0100)
- systemd support/USE_SYSTEMD option was added since 2.30.0,
  so add an optional dependency

Fixes:

  -- Could NOT find Systemd (missing: Systemd_LIBRARY Systemd_INCLUDE_DIR)
  CMake Error at Source/cmake/OptionsGTK.cmake:425 (message):
    libsystemd is needed for USE_SYSTEMD

Reported-by: C Larbi <pkl2000us@gmail.com>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Acked-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webkitgtk/webkitgtk.mk

index 5209eeed2d03879b570fc86fe652f1607cf562ec..84078f8b9abb0f3369f041c390d8e1eb8e2f5495 100644 (file)
@@ -104,6 +104,13 @@ else
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=ON
+WEBKITGTK_DEPENDENCIES += systemd
+else
+WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=OFF
+endif
+
 # JIT is not supported for MIPS r6, but the WebKit build system does not
 # have a check for these processors. The same goes for ARMv5 and ARMv6.
 # Disable JIT forcibly here and use the CLoop interpreter instead.