core/pkg-infra: really build all dependencies of foo with foo-depends
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 2 Jul 2019 20:12:50 +0000 (22:12 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 3 Jul 2019 21:04:50 +0000 (23:04 +0200)
Currently, foo-depends only builds build dependencies. This means that
download and extract dependencies are not built.

First, but a minor point, this is inconsistent with foo-show-depends,
which does display all dependencies:

    $ make host-gzip-show-depends
    host-skeleton host-tar
    $ make host-gzip-depends
        # Only host-skeleton is built and installed

Second, and more important, it makes it more difficult to preapre a
debug build, like so:

    $ make foo-depends
    $ tar cf output.tar output
    $ make foo
        # bummer, broken
        # edit foo.mk to try and fix it
    $ rm -rf output; tar xf output.tar
        # rince and repeat

Change foo-depends so that it really builds all the dependencies for
foo, bringing it on-par with foo-show-depends.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/pkg-generic.mk

index b00967c6481a7eb13edc5db07775c1cc1a799729..9620dec52497e0fd730d41080f9ed600fa3653bd 100644 (file)
@@ -801,7 +801,7 @@ $(1)-extract:                       $$($(2)_TARGET_EXTRACT)
 $$($(2)_TARGET_EXTRACT):       $$($(2)_TARGET_SOURCE)
 $$($(2)_TARGET_EXTRACT): | $$($(2)_FINAL_EXTRACT_DEPENDENCIES)
 
-$(1)-depends:          $$($(2)_FINAL_DEPENDENCIES)
+$(1)-depends:          $$($(2)_FINAL_ALL_DEPENDENCIES)
 
 $(1)-source:           $$($(2)_TARGET_SOURCE)
 $$($(2)_TARGET_SOURCE): | $$($(2)_FINAL_DOWNLOAD_DEPENDENCIES)