libcdio: make C++ support optional
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 21:05:45 +0000 (22:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 21:05:45 +0000 (22:05 +0100)
C++ support is only needed for the example programs (that we don't build)
and C++ bindings.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libcdio/Config.in
package/libcdio/libcdio.mk

index d2d61e7bd0710db7dcfc870464d8f16ed5766f87..555eb2915eeeb4bf88590d6c3193faea9f28db17 100644 (file)
@@ -1,11 +1,7 @@
 config BR2_PACKAGE_LIBCDIO
        bool "libcdio"
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
-       depends on BR2_INSTALL_LIBSTDCPP
        help
          The GNU Compact Disc Input and Control library.
 
          http://www.gnu.org/software/libcdio/
-
-comment "libcdio needs a toolchain w/ C++"
-       depends on !BR2_INSTALL_LIBSTDCPP
index b11480904228fc098d20110f4d984f1efeec14fc..b9aec9e929d155f2807d24371c069e3798ec307b 100644 (file)
@@ -15,6 +15,10 @@ ifeq ($(BR2_ENABLE_LOCALE),)
 LIBCDIO_DEPENDENCIES += libiconv
 endif
 
+ifeq ($(BR2_INSTALL_LIBSTDCPP),)
+LIBCDIO_CONF_OPT += --disable-cxx
+endif
+
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 LIBCDIO_DEPENDENCIES += ncurses
 else