python-cheetah: new package
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Sun, 21 Dec 2014 15:26:55 +0000 (16:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Dec 2014 20:58:48 +0000 (21:58 +0100)
[Thomas:
 - Remove dependency on host-python-markdown, apparently not needed
   (it builds fine in a minimal chroot, which doesn't have
   python-markdown installed)
 - Remove runtime dependency on markdown, I can run Cheetah basic
   examples without python-markdown installed.
 - Add dependency on Python 2 only, since it doesn't build for Python
   3.]

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-cheetah/Config.in [new file with mode: 0644]
package/python-cheetah/python-cheetah.mk [new file with mode: 0644]

index e27a80466f561937d685f948414729d9ae906a6b..5a7616bc27046816bdf52a9579af66fac17512d2 100644 (file)
@@ -489,6 +489,7 @@ menu "external python modules"
        source "package/python-bottle/Config.in"
        source "package/python-certifi/Config.in"
        source "package/python-cffi/Config.in"
+       source "package/python-cheetah/Config.in"
        source "package/python-configobj/Config.in"
        source "package/python-configshell-fb/Config.in"
        source "package/python-crc16/Config.in"
diff --git a/package/python-cheetah/Config.in b/package/python-cheetah/Config.in
new file mode 100644 (file)
index 0000000..e98dc39
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PYTHON_CHEETAH
+       bool "python-cheetah"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         Cheetah is an open source template engine and code generation tool.
+
+         It can be used standalone or combined with other tools and frameworks.
+         Web development is its principle use, but Cheetah is very flexible
+         and is also being used to generate C++ game code, Java, sql, form
+         emails and even Python code.
+
+         https://pypi.python.org/pypi/Cheetah/
diff --git a/package/python-cheetah/python-cheetah.mk b/package/python-cheetah/python-cheetah.mk
new file mode 100644 (file)
index 0000000..08076b5
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-cheetah
+#
+################################################################################
+
+PYTHON_CHEETAH_VERSION = 2.4.4
+PYTHON_CHEETAH_SOURCE = Cheetah-$(PYTHON_CHEETAH_VERSION).tar.gz
+PYTHON_CHEETAH_SITE = http://pypi.python.org/packages/source/C/Cheetah
+PYTHON_CHEETAH_LICENSE = MIT
+PYTHON_CHEETAH_SETUP_TYPE = setuptools
+
+$(eval $(python-package))