kmod: python support works with python 3.x as well
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 11 Apr 2014 22:58:01 +0000 (00:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 11 Apr 2014 22:58:01 +0000 (00:58 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kmod/kmod.mk

index 398740712cfeeeb0acc91d6c48769e91685ef653..7cc2d655e97b28701311aa6f98769a3e6c51f4c1 100644 (file)
@@ -32,8 +32,8 @@ KMOD_DEPENDENCIES += xz
 KMOD_CONF_OPT += --with-xz
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON),y)
-KMOD_DEPENDENCIES += python
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
+KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
 KMOD_CONF_OPT += --enable-python
 endif