package/Makefile: add C-SKY ABI variable value
authorGuo Ren <ren_guo@c-sky.com>
Fri, 31 May 2019 06:39:02 +0000 (14:39 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 31 May 2019 20:59:57 +0000 (22:59 +0200)
In preparation for adding support for the C-SKY architecture in the
internal toolchain backend, we need to make sure that GNU_TARGET_NAME
will contain the appropriate ABI, i.e abiv1 or abiv2 depending on the
selected C-SKY core.

Signed-off-by: Guo Ren <ren_guo@c-sky.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Makefile.in

index dc818a2c188e365ef1a18b48ce9deab35730f86e..f05b9cc3aadf8ae7fee74b02f3f81ac466e6305c 100644 (file)
@@ -70,6 +70,15 @@ ABI := $(ABI)hf
 endif
 endif
 
+# For C-SKY abiv1 & abiv2
+ifeq ($(BR2_csky),y)
+ifeq ($(BR2_ck610),y)
+ABI = abiv1
+else
+ABI = abiv2
+endif
+endif
+
 # For FSL PowerPC there's SPE
 ifeq ($(BR2_powerpc_SPE),y)
 ABI = spe