iptables: disable static for dynamic builds
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 21 Oct 2014 16:58:14 +0000 (13:58 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 19:37:53 +0000 (21:37 +0200)
It leads to ugly runtime warnings, see:
http://patchwork.ozlabs.org/patch/386215/
It's also required for xtables-addons.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iptables/iptables.mk

index f059807b63fbc7195cc51dd1118408ee7b0e0a6d..2ef879d85e136df3468adab44995d948a01d723d 100644 (file)
@@ -12,7 +12,9 @@ IPTABLES_DEPENDENCIES = host-pkgconf \
        $(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)
 IPTABLES_LICENSE = GPLv2
 IPTABLES_LICENSE_FILES = COPYING
-IPTABLES_CONF_OPTS = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr
+# Building static causes ugly warnings on some plugins
+IPTABLES_CONF_OPTS = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr \
+       $(if $(BR2_PREFER_STATIC_LIB),,--disable-static)
 # Because of iptables-01-fix-static-link.patch
 IPTABLES_AUTORECONF = YES