Bump pcre to 7.9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 2 Dec 2009 15:39:21 +0000 (12:39 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 Dec 2009 15:28:12 +0000 (16:28 +0100)
Closes #763.

[Peter: Only remove pcre-config from target if !BR2_HAVE_DEVFILES]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/pcre/pcre.mk

diff --git a/CHANGES b/CHANGES
index 04c677bd2fc8aff00eb7d91fac529a3f995fe460..aed22981833a5c9b5b4fe8cbe3a855cd967be4d7 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -1,12 +1,13 @@
 2010.02, Not yet released:
 
-       Updated/fixed packages: autoconf, binutils, busybox, lighttpd
+       Updated/fixed packages: autoconf, binutils, busybox, lighttpd, pcre
 
        Issues resolved (http://bugs.uclibc.org):
 
        #751: Kernel 2.6 snapshot fetch fail
        #753: Bump lighttpd package to 1.4.25
        #761: Add binutils 2.20 to toolchain options
+       #763: [SECURITY] Update pcre to 7.9
 
 2009.11, Released December 1st, 2009:
 
index 647399ea06a886e17ddea0998e37d5c63ac01c50..290e53431a76ced75bdcb1ac91ceb7233dc7a2c6 100644 (file)
@@ -3,11 +3,10 @@
 # PCRE
 #
 #############################################################
-PCRE_VERSION = 7.7
-PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
+
+PCRE_VERSION = 7.9
 PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
 PCRE_INSTALL_STAGING = YES
-PCRE_INSTALL_TARGET = YES
 
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # pcre will use the host g++ if a cross version isn't available
@@ -21,4 +20,7 @@ $(PCRE_HOOK_POST_INSTALL): $(PCRE_TARGET_INSTALL_TARGET)
                -e 's,^exec_prefix=.*,exec_prefix=$(STAGING_DIR)/usr,' \
                $(STAGING_DIR)/usr/bin/pcre-config
        rm -rf $(TARGET_DIR)/usr/share/doc/pcre
+ifneq ($(BR2_HAVE_DEVFILES),y)
+       rm -f $(TARGET_DIR)/usr/bin/pcre-config
+endif
        touch $@