package/systemd: fixup RPATH for more systemd host binaries
authorNorbert Lange <nolange79@gmail.com>
Mon, 15 Jun 2020 22:28:55 +0000 (00:28 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 17 Jun 2020 20:35:54 +0000 (22:35 +0200)
All systemd binaries depend on libsystemd-shared and need their RPATH
fixed. Use a glob to catch them all.

We can't use $(wildcard ...) because this is expanded before any file
may exist (it's in the same rule that install those file, and the
expansion in Makefile is done once at the beginning of the recipe).

We need to test each file:
 1. to ignore files that were not build (e.g. because the host is
    missing some dependencies (in which case we don't care; we're only
    interested in systemctl, and that one is already built)
 2. to ensure the glob was expanded (in case no file would match
    systemd-*)

Signed-off-by: Norbert Lange <nolange79@gmail.com>
[yann.morin.1998@free.fr:
  - don't use 'set -e', use the more traditional '|| eixt 1'
  - don't cd into HOST_DIR/bin, but use $(addprefix ...)
  - use positive logic in the test
  - expand commit log
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/systemd/systemd.mk

index 1fcffdb3a9d6a58351d32f01858229b3a3e6cfd3..8e01a0db5bb513f987a0823e379606a5b66e35c5 100644 (file)
@@ -641,6 +641,8 @@ HOST_SYSTEMD_DEPENDENCIES = \
        host-libcap \
        host-gperf
 
+HOST_SYSTEMD_NINJA_ENV = DESTDIR=$(HOST_DIR)
+
 # Fix RPATH After installation
 # * systemd provides a install_rpath instruction to meson because the binaries
 #   need to link with libsystemd which is not in a standard path
@@ -649,20 +651,14 @@ HOST_SYSTEMD_DEPENDENCIES = \
 # * the original path had been tweaked by buildroot via LDFLAGS to add
 #   $(HOST_DIR)/lib
 # * thus re-tweak rpath after the installation for all binaries that need it
-HOST_SYSTEMD_HOST_TOOLS = \
-       systemd-analyze \
-       systemd-machine-id-setup \
-       systemd-mount \
-       systemd-nspawn \
-       systemctl \
-       udevadm
-
-HOST_SYSTEMD_NINJA_ENV = DESTDIR=$(HOST_DIR)
+HOST_SYSTEMD_HOST_TOOLS = busctl journalctl systemctl systemd-* udevadm
 
 define HOST_SYSTEMD_FIX_RPATH
-       $(foreach f,$(HOST_SYSTEMD_HOST_TOOLS), \
-               $(HOST_DIR)/bin/patchelf --set-rpath $(HOST_DIR)/lib:$(HOST_DIR)/lib/systemd $(HOST_DIR)/bin/$(f)
-       )
+       for f in $(addprefix $(HOST_DIR)/bin/,$(HOST_SYSTEMD_HOST_TOOLS)); do \
+               [ -e $$f ] || continue; \
+               $(HOST_DIR)/bin/patchelf --set-rpath $(HOST_DIR)/lib:$(HOST_DIR)/lib/systemd $${f} \
+               || exit 1; \
+       done
 endef
 HOST_SYSTEMD_POST_INSTALL_HOOKS += HOST_SYSTEMD_FIX_RPATH