gdb: add avr32 special verson
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 10:38:58 +0000 (11:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Dec 2009 22:54:43 +0000 (23:54 +0100)
 * Add a new gdb version for AVR32 in Config.in

 * Use a special mirror for this gdb version in gdb.mk

 * Do not try to apply patches when the patch directory does not exist
   in gdb.mk

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gdb/Config.in
toolchain/gdb/gdb.mk

index e193fb93ce3e8438dad39e563d46d380adf703ed..947cd1137c4643813da38ab23e11fe2950932c22 100644 (file)
@@ -20,7 +20,7 @@ config BR2_PACKAGE_GDB_HOST
 choice
        prompt "GDB debugger Version"
        default BR2_GDB_VERSION_6_8 if !BR2_avr32
-       default BR2_GDB_VERSION_6_7_1 if BR2_avr32
+       default BR2_GDB_VERSION_6_7_1_AVR32_2_1_5 if BR2_avr32
        depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
        help
          Select the version of gdb you wish to use.
@@ -43,6 +43,10 @@ choice
        config BR2_GDB_VERSION_6_7_1
                bool "gdb 6.7.1"
 
+       config BR2_GDB_VERSION_6_7_1_AVR32_2_1_5
+               depends on BR2_avr32
+               bool "gdb 6.7.1-avr32-2.1.5"
+
        config BR2_GDB_VERSION_6_8
                bool "gdb 6.8"
                depends on !BR2_avr32
@@ -55,4 +59,5 @@ config BR2_GDB_VERSION
        default "6.5"      if BR2_GDB_VERSION_6_5
        default "6.6"      if BR2_GDB_VERSION_6_6
        default "6.7.1"    if BR2_GDB_VERSION_6_7_1
+       default "6.7.1-avr32-2.1.5" if BR2_GDB_VERSION_6_7_1_AVR32_2_1_5
        default "6.8"      if BR2_GDB_VERSION_6_8
index 4c72a21c84df110171b26da460a6e118dbb138f5..bdefd099a3e2d0840adb706e311f535710d3c4a5 100644 (file)
@@ -11,11 +11,14 @@ GDB_SOURCE:=gdb-$(GDB_OFFICIAL_VERSION).tar.bz2
 GDB_CAT:=$(BZCAT)
 
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SOURCE),y)
-GDB_SITE:=$(VENDOR_SITE)
-GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_OFFICIAL_VERSION)
+ GDB_SITE:=$(VENDOR_SITE)
+ GDB_PATCH_DIR:=toolchain/gdb/ext_source/$(VENDOR_PATCH_DIR)/$(GDB_OFFICIAL_VERSION)
+else ifeq ($(findstring avr32,$(GDB_VERSION)),avr32)
+ GDB_SITE:=ftp://www.at91.com/pub/buildroot/
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
 else
-GDB_SITE:=$(BR2_GNU_MIRROR)/gdb
-GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
+ GDB_SITE:=$(BR2_GNU_MIRROR)/gdb
+ GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
 endif
 
 ifneq ($(filter xtensa%,$(ARCH)),)
@@ -37,7 +40,9 @@ ifeq ($(GDB_VERSION),snapshot)
                tar jtf $(DL_DIR)/$(GDB_SOURCE) | head -1 | cut -d"/" -f1)
        ln -sf $(TOOLCHAIN_DIR)/$(shell tar jtf $(DL_DIR)/$(GDB_SOURCE) | head -1 | cut -d"/" -f1) $(GDB_DIR)
 endif
+ifneq ($(wildcard $(GDB_PATCH_DIR)),)
        toolchain/patch-kernel.sh $(GDB_DIR) $(GDB_PATCH_DIR) \*.patch $(GDB_PATCH_EXTRA)
+endif
        $(CONFIG_UPDATE) $(@D)
        touch $@