ipmiutil: openssl support needs shared library
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 17 May 2015 12:02:05 +0000 (14:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 May 2015 12:07:26 +0000 (14:07 +0200)
Fixes:
http://autobuild.buildroot.net/results/0d4/0d4e0ea8fdb233ea8e86f86b6fa406311a0279e2/
http://autobuild.buildroot.net/results/907/907ae0feb9ad2e4a0da4b38290a2b617cb4360a0/

The ipmiutil buildsystem doesn't take dependencies of libcrypto (E.G. zlib)
into consideration, causing link issues when linking statically.

The build system doesn't handle LIBS, so there is no simple way to fix this
outside patching the buildsystem.  As we are very close to the release, lets
just mark it as !static for now.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ipmiutil/ipmiutil.mk

index f03ad9b3943532f73fae8d3f0280e8620aec34cf..011c0b67a708fc548605488b892987e791f51e4f 100644 (file)
@@ -11,7 +11,8 @@ IPMIUTIL_LICENSE_FILES = COPYING
 # We're patching configure.ac
 IPMIUTIL_AUTORECONF = YES
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
+# forgets to link against libcrypto dependencies breaking static link
+ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
 # tests against distro libcrypto so it might get a false positive when
 # the openssl version is old, so force it off
 # SKIP_MD2 can be used only if ALLOW_GNU is defined.