package/vlc: skins2 depends on qt5base
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 21 Aug 2018 20:32:55 +0000 (22:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Aug 2018 20:50:55 +0000 (22:50 +0200)
Fixes

configure: error: The skins2 module depends on the Qt interface. Without
it you will not be able to open any dialog box from the interface, which
makes the skins2 interface rather useless. Install the Qt development
package or alternatively you can also configure with: --disable-qt
--disable-skins2.

http://autobuild.buildroot.net/results/ddb/ddb1ab48adb9705c44ed3d6d800b6d01ad52ac8c/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index c77c945a34823141c9b437ffc910c577ed24936a..b69657d31f0496aa05599cdc8170142e68a64172 100644 (file)
@@ -473,8 +473,14 @@ endif
 ifeq ($(BR2_PACKAGE_QT5BASE_WIDGETS)$(BR2_PACKAGE_QT5SVG),yy)
 VLC_CONF_OPTS += --enable-qt
 VLC_DEPENDENCIES += qt5base qt5svg
+ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT)$(BR2_PACKAGE_XLIB_LIBXINERAMA)$(BR2_PACKAGE_XLIB_LIBXPM),yyy)
+VLC_CONF_OPTS += --enable-skins2
+VLC_DEPENDENCIES += xlib_libXext xlib_libXinerama xlib_libXpm
 else
-VLC_CONF_OPTS += --disable-qt
+VLC_CONF_OPTS += --disable-skins2
+endif
+else
+VLC_CONF_OPTS += --disable-qt --disable-skins2
 endif
 
 ifeq ($(BR2_PACKAGE_SDL_IMAGE),y)
@@ -551,13 +557,6 @@ else
 VLC_CONF_OPTS += --without-x
 endif
 
-ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT)$(BR2_PACKAGE_XLIB_LIBXINERAMA)$(BR2_PACKAGE_XLIB_LIBXPM),yyy)
-VLC_CONF_OPTS += --enable-skins2
-VLC_DEPENDENCIES += xlib_libXext xlib_libXinerama xlib_libXpm
-else
-VLC_CONF_OPTS += --disable-skins2
-endif
-
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 VLC_DEPENDENCIES += zlib
 endif