mpd: add jack output support option
authorPieter De Gendt <pieter.degendt@gmail.com>
Fri, 8 Aug 2014 13:11:32 +0000 (15:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Oct 2014 22:10:06 +0000 (23:10 +0100)
[Thomas: reworked patch on top of the latest master.]

Signed-off-by: Pieter De Gendt <pieter.degendt@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpd/Config.in
package/mpd/mpd.mk

index ac9ca95235c74619ee3b94878b6c1307a534c087..1d38b1a3de0481cc9ea0a737d9d62a1374a14dac 100644 (file)
@@ -229,6 +229,18 @@ config BR2_PACKAGE_MPD_AO
        help
          Enable libao output support.
 
+config BR2_PACKAGE_MPD_JACK2
+       bool "jack2"
+       depends on BR2_LARGEFILE # jack2 -> libsndfile
+       depends on BR2_ARCH_HAS_ATOMICS
+       select BR2_PACKAGE_JACK2
+       help
+         Enable jack output support.
+
+comment "jack support needs a toolchain w/ largefile"
+       depends on BR2_ARCH_HAS_ATOMICS
+       depends on !BR2_LARGEFILE
+
 config BR2_PACKAGE_MPD_PULSEAUDIO
        bool "pulseaudio"
        depends on BR2_LARGEFILE # pulseaudio -> libsndfile
index d7b912bd2870a2fc516555c659914927c55e9605..6d2918d63df7f069ea42f1df9b68bc9dd3236466 100644 (file)
@@ -92,6 +92,13 @@ else
 MPD_CONF_OPTS += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
+MPD_DEPENDENCIES += jack2
+MPD_CONF_OPTS += --enable-jack
+else
+MPD_CONF_OPTS += --disable-jack
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_LAME),y)
 MPD_DEPENDENCIES += lame
 MPD_CONF_OPTS += --enable-lame-encoder