package/kbd: Fix broken Makefile when host-gettext was built before kbd
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 9 Feb 2016 06:46:17 +0000 (07:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Feb 2016 16:58:02 +0000 (17:58 +0100)
This patch uses the same solution used for util-linux:
https://git.busybox.net/buildroot/commit/package/util-linux?id=71f279f9a2bd3f086f3d31fa5a669d3f638bee99

To trigger the bug just build host-gettext before kbd.

Fixes
http://autobuild.buildroot.net/results/87e/87ea83ae4e7b7640651acd5031a624ca42e5b348/
http://autobuild.buildroot.net/results/532/532684b98e050cf5b4c50786bc9e8825eab21f97/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kbd/kbd.mk

index 8da153f2ebf6b3e89ef9f6c2443b3b06167eae97..9dabce13b1c0f301768eb10e7d69147b57f78119 100644 (file)
@@ -17,4 +17,6 @@ KBD_LICENSE = GPLv2+
 KBD_LICENSE_FILES = COPYING
 KBD_AUTORECONF = YES
 
+KBD_INSTALL_TARGET_OPTS += MKINSTALLDIRS=$(@D)/config/mkinstalldirs
+
 $(eval $(autotools-package))