package/mesa3d: add llvm-config to meson [binaries]
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 28 Sep 2019 20:04:31 +0000 (22:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 5 Oct 2019 20:16:19 +0000 (22:16 +0200)
The meson buildsystem does not honour environment variables; instead, it
insists that path to programs be passed in the [binaries] section of the
cross-compilation.conf.

So, that is what we must do to pass the path to llvm-config.

Note that, LLVM_CONFIG does exist in the mesa3d source code, but it is
limited to the Scons buildsystem, and is also a leftover from when
mesa3d was using the autotools. It has never worked with the meson
buildsystem.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Tested-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d/mesa3d.mk

index 35fe2bdbe56d7dbc5d4bb972c87acef36b401ea4..03a9c49a69d2ee05ba8aed52b5c7ee10f3c1e470 100644 (file)
@@ -33,7 +33,7 @@ MESA3D_CONF_OPTS = \
 
 ifeq ($(BR2_PACKAGE_MESA3D_LLVM),y)
 MESA3D_DEPENDENCIES += host-llvm llvm
-MESA3D_CONF_ENV += LLVM_CONFIG=$(STAGING_DIR)/usr/bin/llvm-config
+MESA3D_MESON_EXTRA_BINARIES += llvm-config='$(STAGING_DIR)/usr/bin/llvm-config'
 MESA3D_CONF_OPTS += -Dllvm=true
 else
 # Avoid automatic search of llvm-config