package/gcc: disable libitm for sparc <v9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Jan 2015 00:29:44 +0000 (21:29 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Jan 2015 08:36:16 +0000 (09:36 +0100)
libitm (transactional memory) needs SPARC V9+ ISA, otherwise when
enabling C++ the toolchain fails to build:

/tmp/cclQ6hrD.s: Assembler messages:
/tmp/cclQ6hrD.s:1261: Error: Architecture mismatch on "rd".
/tmp/cclQ6hrD.s:1261:  (Requires v9|v9a|v9b; requested architecture is
v8.)
Makefile:517: recipe for target 'beginend.lo' failed
make[5]: *** [beginend.lo] Error 1

So disable it for our current (v8, leon3) support.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index cdd71aad8cb14a6357d31553fa483b0a2d03a906..2e8b41216e592324454fef1eb297722aef94b21e 100644 (file)
@@ -110,6 +110,11 @@ else
 HOST_GCC_COMMON_CONF_OPTS += --enable-target-optspace
 endif
 
+# libitm needs sparc V9+
+ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
+HOST_GCC_COMMON_CONF_OPTS += --disable-libitm
+endif
+
 # gcc 4.6.x quadmath requires wchar
 ifneq ($(BR2_TOOLCHAIN_BUILDROOT_WCHAR),y)
 HOST_GCC_COMMON_CONF_OPTS += --disable-libquadmath